Monday, November 16, 2020 [Tweets] [Favorites]

Safari 14.0.1 Is Missing Icons

FrakeTrain:

Still on Catalina 10.15.7 SuppUp and just installed Safari 14.0.1 (15610.2.11.51.10) over 14.0 today, and all my .webloc icon previews are blank. That includes desktop icons, folder icons, and Get Info Preview icons.

Both my .webloc and .webarchive files now show only generic document icons. I’ve heard from others that the files no longer even open, but I’m not seeing that problem. On my Mac, it seems likely purely an icon display issue.

Safari 14.0.1 does fix the services bug that I was seeing, but only for some services.

Previously:

Update (2020-12-08): bazaarsoft:

I have a standard web form which has a file selector form field. This has worked for well over 10 years as it’s the standard UI presented by Safari. Just noticed today after Safari upgraded to 14.0.1 (on the latest Mojave) that the button is dead: clicking does nothing. This same form continues to work in Chrome.

Update (2020-12-18): The icons are still missing in Safari 14.0.2.

Update (2021-01-01): Mr. Macintosh:

The Safari 14.0.1 upload issue is not fixed in 14.0.2.

A simple example of this is using Gmail in Safari. If you update to Safari 14.0.1 or 14.0.2 you will be unable to attach anything to an email The only work around right now is to use Chrome or Firefox.

New workaround = drag and drop the file into the window.

4 Comments

Yes some services still fail (UnicodeChecker conversions insert a blank character…) on both macOS 10.15 and 11. on the other hand, .webloc icon display the correct icon the macOS 11 machine, but not the other one (blank).

Me too. It makes me nervous. Any way to fix it?

Even worse, Safari 14.0.1 broke basic file uploading functionality on Mojave! https://discussions.apple.com/thread/252051818

The missing icons and file upload bugs both seem to be fixed in Safari 14.0.3

Stay up-to-date by subscribing to the Comments RSS Feed for this post.

Leave a Comment