Monday, March 30, 2020 [Tweets] [Favorites]

“Cursor,” “Pointer,” and “Insertion Point”

John Gruber:

For clarity, it’s best not to refer to either of these things as cursors. Instead:

  • Mouse/trackpad pointer.
  • Insertion point.

This terminology has been slightly confusing over the last week, since Apple’s surprise announcement of pointer support in iPadOS 13.4. In their marketing materials, Apple is calling pointers “cursors”.

[…]

In its technical documentation, Apple is clear.

The new API calls it a “pointer,” but Carbon and Cocoa have historically used “cursor.” Of course, “pointer” also has another meaning in code.

Dr. Drang:

For 35 years, Apple’s been telling me this thing should called a pointer, and I’ve been following along, mainly because I thought the distinction between a pointer and a cursor was useful.

Previously:

3 Comments

Cursor also has a specific meaning in the database domain. Overloaded terms are everywhere.

I feel like these terms have always been confusing to regular people not steeped in technical jargon. Any time I need to communicate about these things I stay away from the bare terms "cursor" and "pointer". It's better to always just use the longer and unambiguous "mouse cursor" or "mouse pointer", at least initially to establish context.

If a particular document is consistently only talking about the mouse/trackpad then maybe subsequent uses of the term can be shorted to just "cursor" or "pointer, but I'd never do that if there are also references to the text insertion point in the same document. The noun phrase "text insertion point" is quite clear, though I personally don't mind using the shorter "text caret" once the context is clear.

Stay up-to-date by subscribing to the Comments RSS Feed for this post.

Leave a Comment