Marco Arment asks what to name a method that factors out shared code, so it can be called from multiple initializers. The results seem to indicate that there is no agreed upon standard. Apple seems to use
-commonInit, but when subclasses are involved it’s probably better to use a name like
-commonInitForClass. I lean toward
-setUpClass, which is shorter and more verby.
Stay up-to-date by subscribing to the Comments RSS Feed for this post.